Issues processing BPay/Batch Payments

Incident Report for Zai

Resolved

This incident has been resolved
Posted May 09, 2022 - 16:50 AEST

Investigating

We've identified issues being experienced on BPay Payments. We apologise for any inconvenience and will post further updates as they become available.
Posted May 09, 2022 - 11:01 AEST
This incident affected: Payment Processing (Batch).