Investigating issues with Card Payments
Incident Report for Zai
Investigating
We’re currently investigating a potential service interruption with our Card Payments. We apologise for any inconvenience. We will provide more updates as they become available.
Posted Jun 23, 2022 - 13:47 AEST
This incident affects: Payment Processing (Cards).