Investigating issues with Fast Payments
Incident Report for Zai
Resolved
This incident has been resolved. Service interruption on our Fast Payments service is no longer being encountered. We apologise for any inconvenience this may have caused.
Posted May 16, 2022 - 19:13 AEST
Identified
We’ve identified a potential service interruption with our Fast Payments. We apologise for any inconvenience and will provide more updates as they become available.
Posted May 16, 2022 - 12:28 AEST
This incident affected: Payment Processing (Fast Payments).