Investigating issues with Fast Payments
Incident Report for Zai
Resolved
The incident has been resolved. We apologise for any inconvenience this has caused.
Posted Jun 21, 2022 - 21:24 AEST
Investigating
We’re currently experiencing performance issues with our Fast Payments. Our team is currently working to restore normal performance levels. We apologise for any inconvenience and will provide more updates as they become available.
Posted Jun 21, 2022 - 14:11 AEST
This incident affected: Payment Processing (Fast Payments).