Delayed BPAY payments
Incident Report for Zai
Resolved
This incident has been resolved.
Posted Oct 14, 2019 - 21:27 AEDT
Update
We are continuing to monitor for any further issues.
Posted Oct 14, 2019 - 17:41 AEDT
Monitoring
We are currently experiencing delays from our upstream provider for BPAY payments. We will update when we have more information.
Posted Oct 14, 2019 - 17:23 AEDT
This incident affected: Payment Processing (Batch).