BPAY transaction processing delayed
Incident Report for Zai
Resolved
This incident has been resolved.
Posted Jun 03, 2022 - 12:51 AEST
Investigating
While our services remain available, we’re investigating issues being experienced by a third party provider. We apologise for any inconvenience and will post further updates as they become available.
Posted Jun 03, 2022 - 10:32 AEST
This incident affected: Payment Processing (Batch).